Skip to main content
CVE-2025-55673VulnerabilityPublished Updated

CVE-2025-55673: Apache Superset · Information Exposure

Affects Apache SupersetSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 4.1.3 : update Apache Superset when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache SupersetAffected
  • =0
Fixed in–

AI-suggested

European organizations should immediately upgrade Apache Superset to version 4.1.3 or later, where this vulnerability is fixed. If upgrading is not immediately feasible, organizations should disable guest user access or restrict it through network segmentation and access controls to trusted users only. Implement API response filtering or proxy solutions to remove or mask the 'query' field in /chart/data responses for guest users. Conduct thorough audits of Superset configurations to ensure minimal exposure of sensitive information. Additionally, monitor logs for unusual access patterns to the /chart/data endpoint by guest users. Incorporate this vulnerability into vulnerability management and patching workflows to ensure timely updates. Finally, educate developers and administrators about the risks of exposing internal queries and enforce secure coding and configuration practices for BI tools.

Description

When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user. This issue affects Apache Superset: before 4.1.3. Users are recommended to upgrade to version 4.1.3, which fixes the issue.

References

Community reviews

Loading reviews…