CVE-2025-55674: Apache Superset has bypass of `DISALLOWED_SQL_FUNCTIONS` that allows execution of blocked SQL functions
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.0.0 when convenient.
Data as of 4 Nov 2026, 18:16 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 5.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade apache-superset to 5.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIapache-superset | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Superset to version 5.0.0 or later, where this vulnerability is fixed. Since a patch is available and the issue is resolved in the fixed version, applying the official update is the recommended remediation.
Description
Apache Superset before version 5.0.0 contains a vulnerability that allows bypassing the DISALLOWED_SQL_FUNCTIONS security feature. This bypass enables users with SQL Lab access to execute SQL functions that are intended to be blocked, potentially disclosing sensitive database information such as the software version. The issue is fixed in version 5.0.0.