Skip to main content
CVE-2025-55672VulnerabilityPublished Updated

CVE-2025-55672: Apache Superset · Basic XSS

Affects Apache SupersetSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 5.0.0 : update Apache Superset when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache SupersetAffected
  • =0
Fixed in–

AI-suggested

European organizations should immediately upgrade Apache Superset installations to version 5.0.0 or later, where this vulnerability is patched. Until the upgrade is applied, restrict chart editing permissions strictly to trusted users to minimize the risk of malicious payload injection. Implement Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in browsers accessing Superset dashboards. Conduct regular audits of chart configurations to detect suspicious or unexpected HTML content in labels. Educate users about the risks of interacting with untrusted charts and monitor logs for unusual activities related to chart editing or viewing. Additionally, consider isolating Superset instances within secure network segments and enforcing strong authentication and session management controls to reduce the impact of potential session hijacking. Finally, keep abreast of any emerging exploit reports or patches related to this vulnerability.

Description

A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

References

Community reviews

Loading reviews…