Skip to main content
VulnerabilityPublished Updated

CVE-2025-64187: OctoPrint Vulnerable to XSS

Affects octoprintSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64187· Medium 4.6

Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.11.4 when convenient.

Data as of 4 Nov 2026, 18:46 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.04.6
Patch
Available – fixed in 1.11.4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade octoprint to 1.11.4.

Affected software

ProductAffectedFixed in
PyPIoctoprintAffected
  • <1.11.4
Fixed in
  • 1.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OctoPrint version 1.11.4 that fixes this vulnerability. Administrators should upgrade to this version to remediate the issue. As a workaround before patching, disable Action Command notification popups by unchecking 'Enable popups' under OctoPrint Settings -> Printer Notifications, and disable Action Command prompts by setting 'Enable support' to 'Never' under OctoPrint Settings -> Printer Dialogs. Additionally, ensure that print files originate from trusted sources and are preferably sliced with trusted slicer software.

Description

OctoPrint versions up to and including 1.11.3 are vulnerable to a cross-site scripting (XSS) flaw in the Action Command notification and prompt popups. This allows an attacker to inject arbitrary HTML and JavaScript if a victim prints a specially crafted file. Exploitation can disrupt prints, extract sensitive information, or perform actions on behalf of the user. The issue is fixed in version 1.11.4. Administrators can mitigate risk by disabling popups for Action Command notifications and prompts and ensuring print files come from trusted sources.

References

Community reviews

Loading reviews…