Skip to main content
CVE-2025-65028VulnerabilityPublished

CVE-2025-65028: lukevella rallly · Improper Authorization

Affects lukevella ralllySource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.5.4 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade lukevella/rallly to 4.5.4.

Affected software

ProductAffectedFixed in
GitHublukevella/ralllypkg:github/lukevella/ralllyOther threatsAffected
  • <4.5.4
Fixed in
  • 4.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Rallly installations to version 4.5.4 or later, where the vulnerability is patched by enforcing proper authorization checks on vote modification requests. Organizations should audit their current Rallly deployments to identify affected versions and prioritize patching. Additionally, implement strict access controls and monitoring for authenticated users to detect unusual voting activity or unauthorized modifications. Employ logging and alerting mechanisms to track poll vote changes and participantId usage patterns. Where possible, restrict poll modification capabilities to trusted roles or users and consider multi-factor authentication to reduce the risk of compromised accounts. Conduct regular security reviews of collaboration tools and validate that authorization checks are consistently applied across all APIs. Finally, educate users about the importance of account security to mitigate insider threats.

Description

Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an insecure direct object reference (IDOR) vulnerability allows any authenticated user to modify other participants’ votes in polls without authorization. The backend relies solely on the participantId parameter to identify which votes to update, without verifying ownership or poll permissions. This allows an attacker to alter poll results in their favor, directly compromising data integrity. This issue has been patched in version 4.5.4.

References

Community reviews

Loading reviews…