CVE-2025-6593: Wikimedia Foundation MediaWiki · Information Exposure
Affects Wikimedia Foundation MediaWikiSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 1.39.13 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.39.13
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Wikimedia Foundation MediaWiki to 1.39.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia FoundationMediaWiki | Affected
| Fixed in
|
AI-suggested
European organizations should prioritize upgrading MediaWiki installations to versions beyond those affected as soon as official patches are released by the Wikimedia Foundation. If you cannot patch yet, administrators should restrict access to MediaWiki instances, especially limiting public or unauthenticated access to sensitive user-related pages or functions. Implementing strict Content Security Policies (CSP) and input validation can reduce the risk of user interaction-based exploitation. Monitoring web server logs and user activity for unusual patterns or access attempts can help detect exploitation attempts early. Organizations should also educate users about phishing and social engineering risks, as user interaction is required for exploitation. Where feasible, deploying Web Application Firewalls (WAFs) with custom rules to block suspicious requests targeting User.Php or related endpoints can provide additional protection. Regularly auditing MediaWiki configurations and user permissions will minimize exposure of sensitive information. Finally, ensure compliance with data protection regulations by reviewing data handling and access policies related to MediaWiki content.
Description
Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/user/User.Php. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.