Skip to main content
VulnerabilityPublished

CVE-2025-65954: simplesamlphp-module-casserver · Open Redirect

Affects simplesamlphp-module-casserverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.7 Medium : upgrade to 7.0.0 or 6.3.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.0 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0, 6.3.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade simplesamlphp-module-casserver to 7.0.0 or 6.3.1; simplesamlphp/simplesamlphp-module-casserver to 6.3.1.

Affected software

ProductAffectedFixed in
simplesamlphpsimplesamlphp-module-casserverAffected
  • >=7.0.0-rc1 <7.0.0
Fixed in
  • 7.0.0
simplesamlphpsimplesamlphp-module-casserverAffected
  • <6.3.1
Fixed in
  • 6.3.1
GitHubsimplesamlphp/simplesamlphp-module-casserverpkg:github/simplesamlphp/simplesamlphp-module-casserverOther threatsAffected
  • <6.3.1
Fixed in
  • 6.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected installations of simplesamlphp-module-casserver to version 6.3.1 or later, or to version 7.0.0 or later where the issue is fixed. Since this is a module vulnerability and not a cloud service, manual patching by updating the software is required. There is no vendor advisory explicitly stating otherwise, so applying the official fixed versions is the recommended remediation.

Description

SimpleSAMLphp-casserver is a CAS 1.0 and 2.0 compliant CAS server in the form of a SimpleSAMLphp module. In versions below 6.3.1 and 7.0.0, the logout endpoint accepts a url query parameter to redirect to.casserver treats that url as trusted, and either (depending on configuration) redirects the browser there, or shows a "you've been logged out" page with a link to continue to that url. Impacted configs include 'enable_logout' => true, and 'skip_logout_page' -> true. This issue has been resolved in versions 6.3.1 and 7.0.0.

References

Community reviews

Loading reviews…