Skip to main content
CVE-2025-66027VulnerabilityPublished Updated

CVE-2025-66027: lukevella rallly · Information Exposure

Affects lukevella ralllySource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 4.5.6 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade lukevella/rallly to 4.5.6.

Affected software

ProductAffectedFixed in
GitHublukevella/ralllypkg:github/lukevella/ralllyOther threatsAffected
  • <4.5.6
Fixed in
  • 4.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade all Rallly instances to version 4.5.6 or later, where the vulnerability is patched. Organizations should immediately audit their deployments to identify affected versions and apply updates without delay. Additionally, review and tighten access control policies to ensure that only authorized users have access to participant data. Implement network segmentation and monitoring to detect unusual API access patterns. Consider disabling or restricting API endpoints that expose participant information if not essential. Conduct privacy impact assessments to evaluate exposure risks and ensure compliance with GDPR. Educate users and administrators about the risks of information disclosure and enforce strong authentication and authorization mechanisms. Finally, maintain an incident response plan to address potential data leaks promptly.

Description

Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.6, an information disclosure vulnerability exposes participant details, including names and email addresses through the /api/trpc/polls.get,polls.participants.list endpoint, even when Pro privacy features are enabled. This bypasses intended privacy controls that should prevent participants from viewing other users’ personal information. This issue has been patched in version 4.5.6.

References

Community reviews

Loading reviews…