Skip to main content
CVE-2025-67942VulnerabilityPublished Updated

CVE-2025-67942: Peach Payments Gateway (WordPress plugin) · Missing Authorization

Affects Peach Payments Gateway (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.3.7 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Peach Payments Gateway (WordPress plugin) to 3.3.7.

Affected software

ProductAffectedFixed in
peachpaymentsPeach Payments GatewayAffected
  • <3.3.7
Fixed in
  • 3.3.7

AI-suggested

If you cannot patch yet, restrict access to the plugin's administrative interfaces and monitor for unusual activity related to the payment gateway. Avoid exposing the plugin to untrusted users or networks.

Description

Missing Authorization vulnerability in peachpayments Peach Payments Gateway wc-peach-payments-gateway allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Peach Payments Gateway: from n/a through <= 3.3.6.

References

Community reviews

Loading reviews…