Skip to main content
VulnerabilityPublished Updated

CVE-2025-68815: Linux kernel · Use After Free

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in cca2ed931b734fe48139bc6f020e47367346630f : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-16.

Patch
Available – fixed in cca2ed931b734fe48139bc6f020e47367346630f, b1e125ae425aba9b45252e933ca8df52a843ec70, 8067db5c95aab9461d23117679338cd8869831fa +6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=5.10.62 <5.10.248
  • >=5.13.14 <5.14
Fixed in
  • cca2ed931b734fe48139bc6f020e47367346630f
  • b1e125ae425aba9b45252e933ca8df52a843ec70
  • 8067db5c95aab9461d23117679338cd8869831fa
  • 02783a37cb1c0a2bd9fcba4ff1b81e6e209c7d87
  • 58fdce6bc005e964f1dbc3ca716f5fe0f68839a2
  • 43d9a530c8c094d137159784e7c951c65f11ec6c
  • 5.14
  • 5.10.248
  • 2f125ebe47d6369e562f3cbd9b6227cff51eaf34
LinuxLinuxAffected
  • =5.14
Fixed in–

AI-suggested

This vulnerability has been fixed in Linux kernel versions 5.10.248, 5.14, and later. Systems running affected versions (>=5.10.62 <5.10.248, >=5.13.14 <5.14, and =5.14) should be updated to these fixed versions to remediate the issue. No additional mitigation is required once patched.

Description

CVE-2025-68815 is a vulnerability in the Linux kernel's net/sched subsystem related to the ets qdisc scheduler. When a user changes a drr class to a strict class, the code fails to remove the drr class from the active list, potentially causing the class to be added twice if toggled back. This can lead to kernel warnings and crashes due to double list additions. The issue has been fixed by ensuring the class is properly removed from the active list when changed to strict.

References

Community reviews

Loading reviews…