Skip to main content
VulnerabilityPublished Updated

CVE-2025-71331: Flowise · Basic XSS

Affects FlowiseSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium : upgrade to 3.0.8 as a priority.

Data as of 8 Nov 2026, 14:20 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.1
CNA (VulnCheck)CVSS 3.16.1
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-06-22.

Patch
Available – fixed in 3.0.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 20 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 26 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 46 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade Flowise to 3.0.8.

Affected software

ProductAffectedFixed in
FlowiseFlowiseAffected
  • <3.0.8
Fixed in
  • 3.0.8
npmFlowisepkg:npm/FlowiseOther threatsAffected
  • <3.0.8
Fixed in
  • 3.0.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.0.8 or later, where this vulnerability is fixed. No additional mitigation steps are required once the update is applied.

Description

Flowise versions prior to 3.0.8 contain a cross-site scripting (XSS) vulnerability due to insufficient input filtering in chat messages and custom agent functions. This flaw allows attackers to inject malicious JavaScript, such as iframe payloads, which execute in the victim's browser and can lead to theft of cookies and session data. The vulnerability is fixed in version 3.0.8.

References

Community reviews

Loading reviews…