CVE-2025-71419: uvdesk core-framework · Cross-site Scripting
Affects uvdesk core-frameworkSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.1.7 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.7, 1.1.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade core-framework and uvdesk/core-framework to 1.1.7; community-skeleton to 1.1.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| uvdeskcore-framework | Affected
| Fixed in
|
| uvdeskcommunity-skeleton | Affected
| Fixed in
|
GitHubuvdesk/core-frameworkpkg:github/uvdesk/core-frameworkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in UVdesk core-framework version 1.1.7 and later. Users should upgrade to version 1.1.7 or newer to remediate this vulnerability. Patch status is confirmed by the affectedVersions data indicating versions before 1.1.7 are vulnerable. No vendor advisory content was provided, so check UVdesk official resources for the latest remediation guidance.
Description
UVdesk core-framework versions prior to 1.1.7 contain a stored cross-site scripting (XSS) vulnerability in the SwiftMailer configuration identifier parameter. Attackers with the ROLE_AGENT privilege can inject malicious scripts into this parameter, which are then stored and executed when other users access the configuration update page. This vulnerability has a medium severity rating with a CVSS 4.0 score of 5.1.
References
- github.com/uvdesk/core-framework/commit/e5e92d1f5bdb24d1b96751213fb427035736371f (opens in a new tab)
- github.com/uvdesk/core-framework/blob/v1.1.6/Resources/views/SwiftMailer/manageConfigurations.html.twig (opens in a new tab)
- github.com/uvdesk/core-framework/blob/v1.1.6/Controller/SwiftMailer.php (opens in a new tab)
- hackmd.io/@leediay/B1Cz5voFGg (opens in a new tab)
- github.com/uvdesk/core-framework/releases/tag/v1.1.7 (opens in a new tab)
- github.com/uvdesk/community-skeleton/releases/tag/v1.1.8 (opens in a new tab)
- github.com/uvdesk/core-framework (opens in a new tab)
- vulncheck.com/advisories/uvdesk-core-framework-before-1.1.7-stored-xss-via-swiftmailer (opens in a new tab)