CVE-2025-71421: uvdesk core-framework · Improper Privilege Management
Affects uvdesk core-frameworkSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.1.7 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.7, 1.1.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade core-framework and uvdesk/core-framework to 1.1.7; community-skeleton to 1.1.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| uvdeskcore-framework | Affected
| Fixed in
|
| uvdeskcommunity-skeleton | Affected
| Fixed in
|
GitHubuvdesk/core-frameworkpkg:github/uvdesk/core-frameworkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in UVdesk core-framework version 1.1.7 and later. Users should upgrade to version 1.1.7 or newer to remediate this vulnerability. Since the affected software is not a cloud service, remediation requires applying the official patch or upgrading the software accordingly.
Description
UVdesk core-framework versions prior to 1.1.7 contain an improper privilege management vulnerability in the editAgent endpoint. This flaw allows agents who already have agent-management privileges to escalate their own role to administrator by submitting their own account identifier with a role parameter set to ROLE_ADMIN. This grants full administrative control over agents, tickets, and mail configuration. The vulnerability has a high severity with a CVSS 4.0 score of 8.6.
References
- github.com/uvdesk/core-framework/commit/b8bcdc503659f9d5c5cd73627cfc5d45508b9a55 (opens in a new tab)
- github.com/uvdesk/core-framework/blob/v1.1.6/Controller/Account.php (opens in a new tab)
- hackmd.io/@leediay/B1Cz5voFGg (opens in a new tab)
- github.com/uvdesk/core-framework/releases/tag/v1.1.7 (opens in a new tab)
- github.com/uvdesk/community-skeleton/releases/tag/v1.1.8 (opens in a new tab)
- github.com/uvdesk/core-framework (opens in a new tab)
- vulncheck.com/advisories/uvdesk-core-framework-before-1.1.7-privilege-escalation-via-editagent (opens in a new tab)