Skip to main content
VulnerabilityPublished Updated

CVE-2025-8723: Cloudflare Image Resizing (WordPress plugin) · Code Injection

Affects Cloudflare Image Resizing (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · 18% EPSS · CVSS 9.8 Critical · patch available : patch Cloudflare Image Resizing (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
18.0% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
mecanik Cloudflare Image Resizing – Optimize & Accelerate Your ImagesAffected
  • =0
Fixed in–

AI-suggested

An official patch is available for this vulnerability. Users of the Cloudflare Image Resizing plugin should update to the latest version beyond 1.5.6 immediately to remediate the issue. Until patched, restricting access to the REST API endpoints or disabling the plugin may reduce exposure, but updating is the recommended and definitive fix.

Description

The Cloudflare Image Resizing plugin for WordPress is vulnerable to Remote Code Execution due to missing authentication and insufficient sanitization within its hook_rest_pre_dispatch() method in all versions up to, and including, 1.5.6. This makes it possible for unauthenticated attackers to inject arbitrary PHP into the codebase, achieving remote code execution.

References

Community reviews

Loading reviews…