Skip to main content
VulnerabilityPublished

CVE-2026-0393: CODESYS Visualization · Insufficiently Protected Credentials

Affects CODESYS VisualizationSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.10.0.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.10.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CODESYS Visualization to 4.10.0.0.

Affected software

ProductAffectedFixed in
CODESYSVisualizationAffected
  • >=1.0.0.0 <4.10.0.0
Fixed in
  • 4.10.0.0

AI-suggested

If you cannot patch yet, organizations should consider restricting concurrent login sessions for low privileged users or implementing additional network-level controls to limit exposure.

Description

The affected product may expose credentials remotely between low privileged visualization users during concurrent login operations due to insufficient isolation of authentication data. The vulnerability affects only login operations within an active visualization session.

References

Community reviews

Loading reviews…