Skip to main content
CVE-2026-0969VulnerabilityPublished Updated

CVE-2026-0969: HashiCorp Shared library · Improper Control of Generation of Code (Code Injection)

Affects HashiCorp Shared librarySource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 6.0.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade HashiCorp Shared library to 6.0.0.

Affected software

ProductAffectedFixed in
HashiCorpShared libraryAffected
  • >=4.3.0 <6.0.0
Fixed in
  • 6.0.0
GitHubShared librarypkg:github/Shared libraryOther threatsAffected
  • >=4.3.0 <6.0.0
Fixed in
  • 6.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in next-mdx-remote version 6.0.0. Users of affected versions, such as 4.3.0, should upgrade to version 6.0.0 or later to remediate this vulnerability. Since this is not a cloud service, remediation requires applying the updated library version in affected environments. Patch status is confirmed by the vendor advisory stating the issue is fixed in 6.0.0.

Description

The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.

References

Community reviews

Loading reviews…