CVE-2026-101897: angular · Origin Validation Error
Affects angularSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 22.2.0-rc.0 when convenient.
Data as of 29 Oct 2026, 15:07 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 5.1 |
|---|
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-29.
- Patch
- Available – fixed in 22.2.0-rc.0, 1.21.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade angular to 22.2.0-rc.0; angular to 22.2.0-rc.0 or 1.21.1; DevTools to 1.21.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| angularangular | Affected
| Fixed in
|
| angularDevTools | Affected
| Fixed in
|
npmangularpkg:npm/angularOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Angular DevTools to version 1.21.1 or later, or 22.2.0-rc.0 or later, where the issue is fixed. No other mitigation is required as the vulnerability is resolved in these versions.
Description
A vulnerability in Angular DevTools versions from 1.20.0 up to but not including 1.21.1 allows untrusted web pages or third-party content scripts to send messages to the background service worker without proper origin validation. This can enable an attacker who knows a valid victim tabId to cause the extension to attach the debugger to another browser tab and trigger breakpoints, resulting in JavaScript execution pauses and UI interaction blocks. The issue does not allow remote code execution, privilege escalation, or access to sensitive data. The vulnerability is fixed in Angular versions 1.21.1 and 22.2.0-rc.0.
References
- github.com/angular/angular/security/advisories/GHSA-r653-wxfp-pp9c (opens in a new tab)
- github.com/angular/angular/pull/70623 (opens in a new tab)
- github.com/angular/angular/commit/7c053599c79a6ddd785a9bae33ff9fc7b355ea0d (opens in a new tab)
- github.com/angular/angular/commit/cf492e8a372e2bbddb84987df12c33a52c23c72f (opens in a new tab)
- github.com/angular/angular/commit/e02c4d89bcf5da9af499e0dfbba8c29206976ab3 (opens in a new tab)