A vulnerability in Angular DevTools versions 1.20.0 up to but not including 1.21.1 allows untrusted web pages or third-party content scripts to send messages to the background service worker without proper origin validation. This can let an attacker who knows a valid victim tabId cause the extension to attach the debugger to another browser tab and trigger breakpoints, resulting in JavaScript execution pauses and blocking UI interactions. The issue does not permit remote code execution, privilege escalation, or access to sensitive data. The vulnerability is fixed in Angular versions 1.21.1 and 22.2.0-rc.0.
A flaw in AngularJS' Strict Contextual Escaping (SCE) logic allows bypassing certain SCE policies for resource URLs and can lead to arbitrary JavaScript execution within the context of the victim's browser session.
SCE's purpose is to ensure that only trusted or safe values are used in certain security-sensitive contexts, such as resource URLs, including URLs that define executable JavaScript scripts, '<iframe>' documents, route templates, etc. A flaw in the logic that tries to match entire URLs against regular expression matchers can result in partial matches for certain types of regular expressions, effectively bypassing the policies and allowing the use of unsafe values as resource URLs.
This issue affects AngularJS versions greater than or equal to 1.2.0-rc.3.
Note:
The AngularJS project was already End-of-Life when this CVE was published and will not receive any updates to address this issue. For more information see the End-of-Life announcement https://docs.angularjs.org/misc/version-support-status .
CVE-2025-61261 is a reflected cross-site scripting (XSS) vulnerability affecting CKEditor v46.1.0 and Angular v18.0.0. This flaw allows attackers to inject malicious scripts that execute in the context of a user's browser when they interact with crafted payloads. The vulnerability requires user interaction but no authentication, and it can lead to limited confidentiality and integrity impacts without affecting availability. The CVSS score is 5.4 (medium severity), indicating moderate risk. No known exploits are currently reported in the wild.
CVE-2025-0716 is a vulnerability in AngularJS where improper sanitization of the 'href' and 'xlink:href' attributes in SVG <image> elements allows attackers to bypass image source restrictions. This can lead to content spoofing and degrade application performance by loading large or slow images. All AngularJS versions up to 1.8.3 are affected. AngularJS is end-of-life and will not receive patches for this issue.
AngularJS contains a vulnerability in the sanitization of the [srcset] attribute in <source> HTML elements that allows attackers to bypass image source restrictions, potentially leading to content spoofing. This affects all AngularJS versions up to 1.8.3. AngularJS is end-of-life and will not receive patches for this issue.
AngularJS versions from 1.3.0-rc.4 through 1.8.3 have an improper sanitization vulnerability in the [srcset] attribute. This flaw allows attackers to bypass common image source restrictions, potentially leading to content spoofing attacks. AngularJS is end-of-life and will not receive updates to fix this issue.
This affects versions of the package angular from 1.3.0; versions of the package angularjs from 1.3.0. A regular expression used to split the value of the ng-srcset directive is vulnerable to super-linear runtime due to backtracking. With large carefully-crafted input, this can result in catastrophic backtracking and cause a denial of service.
**Note:**
This package is EOL and will not receive any updates to address this issue. Users should migrate to [@angular/core](https://www.npmjs.com/package/@angular/core).
Versions of the package angular from 1.2.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the angular.copy() utility function due to the usage of an insecure regular expression. Exploiting this vulnerability is possible by a large carefully-crafted input, which can result in catastrophic backtracking.
Versions of the package angular from 1.4.9 are vulnerable to Regular Expression Denial of Service (ReDoS) via the <input type="url"> element due to the usage of an insecure regular expression in the input[url] functionality. Exploiting this vulnerability is possible by a large carefully-crafted input, which can result in catastrophic backtracking.
Versions of the package angular from 1.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the $resource service due to the usage of an insecure regular expression. Exploiting this vulnerability is possible by a large carefully-crafted input, which can result in catastrophic backtracking.