Skip to main content
VulnerabilityPublished

CVE-2026-102260: HashiCorp Nomad · Incorrect Authorization

Affects HashiCorp NomadSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.1.0 when convenient.

Data as of 29 Oct 2026, 18:49 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (HashiCorp)CVSS 3.14.3
Patch
Available – fixed in 2.1.0, 1.11.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Nomad and Nomad Enterprise to 2.1.0; Nomad Enterprise to 1.11.12.

Affected software

ProductAffectedFixed in
HashiCorpNomadAffected
  • >=0.11.0 <2.1.0
Fixed in
  • 2.1.0
HashiCorpNomad EnterpriseAffected
  • >=0.11.0 <1.11.12
Fixed in
  • 2.1.0
GitHubNomadpkg:github/NomadOther threatsAffected
  • >=0.11.0 <2.1.0
Fixed in
  • 2.1.0
GitHubNomad Enterprisepkg:github/Nomad EnterpriseOther threatsAffected
  • >=0.11.0 <1.11.12
Fixed in
  • 1.11.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected HashiCorp Nomad and Nomad Enterprise installations to fixed versions: Nomad Community Edition 2.1.0 or later, Nomad Enterprise 2.1.0, 1.11.12, or 1.10.18 or later. These versions contain the official fix for this authorization bypass vulnerability.

Description

HashiCorp Nomad and Nomad Enterprise contain an authorization bypass vulnerability (CVE-2026-102260) affecting several read-only API endpoints. This flaw allows an authenticated user with read permissions in one namespace to access information about objects in other namespaces. The issue is fixed in Nomad Community Edition 2.1.0 and Nomad Enterprise versions 2.1.0, 1.11.12, and 1.10.18.

References

Community reviews

Loading reviews…