Skip to main content
VulnerabilityPublished

CVE-2026-103039: Gravity Forms (WordPress plugin) · Deserialization of Untrusted Data

Affects Gravity Forms (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 3.1.3 : patch Gravity Forms (WordPress plugin) as a priority.

Data as of 30 Oct 2026, 07:14 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.19.8
Patch
Available – fixed in 3.1.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Gravity FormsGravity FormsAffected
  • <=3.1.2
Fixed in–

AI-suggested

A fix is available starting from Gravity Forms version 3.1.3, which uses the hardened GFCommon::maybe_unserialize() function to prevent unsafe object deserialization. Users should upgrade to version 3.1.3 or later to remediate this vulnerability. Until then, restricting access to the vulnerable post custom fields or disabling them may reduce risk, but upgrading is strongly recommended.

Description

Gravity Forms plugin for WordPress versions up to and including 3.1.2 is vulnerable to PHP Object Injection via a Post Custom Field of type List. This occurs because the plugin uses WordPress' maybe_unserialize() without restrictions instead of its own hardened deserialization function. An attacker can inject PHP objects into post meta, potentially leading to remote code execution if a suitable gadget chain exists in other plugins, themes, or WordPress itself.

References

Community reviews

Loading reviews…