Skip to main content
VulnerabilityPublished

CVE-2026-10511: Jupiter X Core (WordPress plugin) · Basic XSS

Affects Jupiter X Core (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium.

Data as of 27 Oct 2026, 08:12 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
artbeesJupiter X CoreAffected
  • <=4.61.0
Fixed in–

AI-suggested

Users should upgrade beyond version 4.61.0 if a fixed version is released in the future. Until then, restrict contributor-level access to trusted users only and consider disabling or limiting use of the affected functionality. Monitor vendor advisories for official remediation guidance.

Description

The Jupiter X Core plugin for WordPress contains a stored cross-site scripting (XSS) vulnerability in the 'forget_password_link' parameter. This flaw affects all versions up to and including 4.61.0. Authenticated users with contributor-level access or higher can inject malicious scripts that execute when other users view the affected pages. The vulnerability arises from insufficient input sanitization and output escaping.

References

Community reviews

Loading reviews…