Skip to main content
VulnerabilityPublished Updated

CVE-2024-7781: Jupiter X Core (WordPress plugin) · Authentication Bypass Using an Alternate Path or Channel

Affects Jupiter X Core (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · fixed in 4.7.8 : patch Jupiter X Core (WordPress plugin) soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.7.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
artbees Jupiter X CoreAffected
  • =0
Fixed in–

AI-suggested

A full official fix is available in Jupiter X Core version 4.7.8. Users should upgrade to version 4.7.8 or later to fully remediate this vulnerability. Partial mitigation in version 4.7.5 is insufficient. Until upgrading, consider disabling or removing the Social Login widget if possible, but note that the vulnerability can still be exploited if the widget was previously enabled and used. Patch status is confirmed by vendor advisories indicating the fix in 4.7.8.

Description

The Jupiter X Core plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 4.7.5. This is due to improper authentication via the Social Login widget. This makes it possible for unauthenticated attackers to log in as the first user to have logged in with a social media account, including administrator accounts. Attackers can exploit the vulnerability even if the Social Login element has been disabled, as long as it was previously enabled and used. The vulnerability was partially patched in version 4.7.5, and fully patched in version 4.7.8.

References

Community reviews

Loading reviews…