Skip to main content
VulnerabilityPublished Updated

CVE-2026-105209: zitadel · Missing Authorization

Affects zitadelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.17.1 as a priority.

Data as of 29 Oct 2026, 20:59 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.3
CNA (VulnCheck)CVSS 3.19.6
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-05.

Patch
Available – fixed in 4.17.1, 3.4.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade zitadel to 4.17.1; zitadel to 3.4.15.

Affected software

ProductAffectedFixed in
zitadelzitadelAffected
  • >=4.0.0 <4.17.1
Fixed in
  • 4.17.1
zitadelzitadelAffected
  • <3.4.15
Fixed in
  • 3.4.15

AI-suggested

Upgrade ZITADEL to version 3.4.15 or later if using the 3.x branch, or to version 4.17.1 or later if using the 4.x branch. These versions contain the official fix for this improper authorization vulnerability. No other mitigation actions are indicated by the vendor advisory.

Description

ZITADEL versions 3.x before 3.4.15 and 4.x before 4.17.1 have an improper authorization vulnerability. The system incorrectly validates the organization when issuing passkey or passwordless enrollment codes, relying only on the x-zitadel-orgid header rather than the target user's actual organization. This flaw allows attackers with user-write permission in one organization to obtain enrollment codes for users in other organizations on the same instance, enabling them to register authenticators and take over those accounts.

References

Community reviews

Loading reviews…