CVE-2026-105619: DALIBO PostgreSQL Anonymizer · Missing Authorization
Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 3.3.0 when convenient.
Data as of 28 Oct 2026, 17:58 UTC
- Patch
- Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DALIBOPostgreSQL Anonymizer | Affected
| Fixed in
|
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where this missing authorization issue is resolved. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-105619 is a vulnerability in DALIBO PostgreSQL Anonymizer versions prior to 3.3.0 where data accessed through a security_invoker view is not properly masked. This missing authorization issue allows unauthorized access to sensitive data. The vulnerability has a CVSS score of 4.8, indicating medium severity. The issue is fixed in version 3.3.0 and later.