Skip to main content
VulnerabilityPublished

CVE-2026-105620: DALIBO PostgreSQL Anonymizer · Missing Authorization

Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.3.0 when convenient.

Data as of 28 Oct 2026, 17:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.3.0.

Affected software

ProductAffectedFixed in
DALIBOPostgreSQL AnonymizerAffected
  • >=1 <3.3.0
Fixed in
  • 3.3.0
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threatsAffected
  • >=1 <3.3.0
Fixed in
  • 3.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where this issue has been fixed. No other mitigation actions are specified or required.

Description

CVE-2026-105620 is a vulnerability in DALIBO PostgreSQL Anonymizer where data returned by a sub-query in a rule is not properly masked. This issue allows unauthorized access to sensitive data. The vulnerability is fixed in version 3.3.0 and later.

References

Community reviews

Loading reviews…