Skip to main content
VulnerabilityPublished Updated

CVE-2026-105933: Apache Pulsar · Failing Open

Affects Apache PulsarSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 4.2.5 or 4.0.14 when convenient.

Data as of 29 Oct 2026, 19:15 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.02.3
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.5, 4.0.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Pulsar and org.apache.pulsar/pulsar to 4.2.5 or 4.0.14.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache PulsarAffected
  • >=4.1.0 <4.2.5
Fixed in
  • 4.2.5
Apache Software FoundationApache PulsarAffected
  • >=1.22.0-incubating <4.0.14
Fixed in
  • 4.0.14
Mavenorg.apache.pulsar/pulsarpkg:maven/org.apache.pulsar/pulsarOther threatsAffected
  • >=1.22.0-incubating <4.0.14
  • >=4.1.0 <4.2.5
Fixed in
  • 4.0.14
  • 4.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Pulsar to version 4.0.14 or later if using the 4.0.x line, or to 4.2.5 or later if using the 4.1.x or 4.2.x lines. For users unable to upgrade immediately, monitor broker logs for warnings indicating that encryption enforcement has been disabled (e.g., messages containing "isEncryptionRequired will be set to false"), resolve the underlying cause of topic initialization failures, and reload affected topics to restore enforcement. Enforcement is reliably restored only after fixing the root cause and reloading the topic.

Description

Apache Pulsar versions from 1.22.0-incubating before 4.0.14 and from 4.1.0 before 4.2.5 have a vulnerability where the encryption_required namespace policy can be bypassed if topic initialization fails. In such cases, the broker disables the encryption requirement for the topic and loads it successfully, allowing authenticated producers to publish unencrypted messages despite the namespace policy. This issue is fixed in versions 4.0.14 and 4.2.5.

References

Community reviews

Loading reviews…