CVE-2026-105946: qt · Out-of-bounds Read
Affects qtSource CVE Database V5
Public exploit available · CVSS 5.3 Medium : upgrade to 6.11.2 or 6.8.10 as a priority.
Data as of 27 Oct 2026, 07:27 UTC
- Patch
- Available – fixed in 6.11.2, 6.8.10
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade qt and org.qtproject/qt to 6.11.2 or 6.8.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| qtqt | Affected
| Fixed in
|
| qtqt | Affected
| Fixed in
|
Mavenorg.qtproject/qtpkg:maven/org.qtproject/qtOther threats | Affected
| Fixed in
|
CPE configurations (2)
cpe:2.3:a:qt:qt:*:*:*:*:*:*:*:*cpe:2.3:a:qt:qtbase:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users and developers should upgrade affected Qt versions to 6.8.10 or later, or 6.11.2 or later, where this vulnerability has been fixed. No other mitigations are indicated by the vendor advisory. Since this is not a cloud service, patching the application using the affected Qt versions is required to remediate the issue.
Description
CVE-2026-105946 is an out-of-bounds read vulnerability in the QAuthenticator NTLM authentication handling within the Qt Network module. It affects applications using QNetworkAccessManager or QTcpSocket that authenticate with NTLM. A malicious server or proxy can send a crafted NTLM challenge to trigger this flaw, potentially exposing sensitive heap memory contents or causing an application crash. The vulnerability affects Qt versions from 6.8.0 up to but not including 6.8.10, and from 6.9.0 up to but not including 6.11.2. Fixed versions are 6.8.10 and 6.11.2. The CVSS 4.0 score is 5.3, indicating medium severity.