Skip to main content
VulnerabilityPublished

CVE-2026-107759: WPO365 | MICROSOFT 365 GRAPH MAILER (WordPress plugin) · Cross-site Scripting

Affects WPO365 | MICROSOFT 365 GRAPH MAILER (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High · patch available : patch WPO365 | MICROSOFT 365 GRAPH MAILER (WordPress plugin) soon.

Data as of 31 Oct 2026, 08:10 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.17.2
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
wpo365WPO365 | MICROSOFT 365 GRAPH MAILERAffected
  • <=6.2
Fixed in–

AI-suggested

A patch is available for this vulnerability. Users should update the WPO365 | MICROSOFT 365 GRAPH MAILER plugin to a fixed version beyond 6.2. Since this is a cloud-hosted service plugin, the vendor manages remediation for the cloud environment; users should verify that OAuth authorization is completed after activation to reduce exposure. Check the vendor advisory for the latest patch and remediation instructions.

Description

The WPO365 | MICROSOFT 365 GRAPH MAILER WordPress plugin is affected by a stored Cross-Site Scripting (XSS) vulnerability in versions up to and including 6.2. This vulnerability arises from insufficient input sanitization and output escaping of the 'Subject' parameter used in mail-sending features. An unauthenticated attacker can inject malicious scripts that execute when users access the affected pages. The issue is present immediately after plugin activation if OAuth authorization is not completed, which is the default state. A fix is available for this vulnerability.

References

Community reviews

Loading reviews…