Skip to main content
VulnerabilityPublished Updated

CVE-2026-109250: FreeRDP · Improper Validation of Array Index

Affects FreeRDPSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.0 High · fixed in 3.0.0 : patch FreeRDP soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.0
CNA (VulnCheck)CVSS 3.16.6
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threatsAffected
  • =3.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the affected versions are specifically 3.0.0 and the vulnerability is fixed in versions after 3.0.0 (before 3.32.0), users should upgrade to FreeRDP 3.32.0 or later once available. Until then, restrict local access to trusted users and avoid using vulnerable versions with untrusted smartcard tokens.

Description

FreeRDP versions 3.0.0 before 3.32.0 have a heap buffer overflow vulnerability in the collect_keys() function. This flaw allows local attackers controlling smartcard tokens to write beyond a fixed 64-entry keys array during PKCS#11 key enumeration, potentially corrupting heap memory with attacker-controlled data during smartcard logon.

References

Community reviews

Loading reviews…