CVE-2026-120064: Several psqlODBC entry points use an application-supplied column number or row index as an array
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 18.00.0006 soon.
Data as of 2 Nov 2026, 23:28 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade psqlODBC to 18.00.0006.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQLpsqlODBC | Affected
| Fixed in
|
GitHubpsqlODBCpkg:github/psqlODBCOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in psqlODBC version 18.00.0006 and later. Users should upgrade to version 18.00.0006 or newer to remediate this vulnerability. Until patched, avoid forwarding untrusted column or row numbers to psqlODBC entry points.
Description
CVE-2026-120064 is a vulnerability in psqlODBC versions before 18.00.0006 where several entry points improperly use application-supplied column numbers or row indexes as array indexes without validation. This can lead to out-of-bounds reads and writes when untrusted inputs are forwarded, potentially causing memory corruption.