Skip to main content
VulnerabilityPublished Updated

CVE-2026-33762: go-git · Improper Validation of Array Index

Affects go-gitSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.8 Low : upgrade to 5.17.1 when convenient.

Data as of 2 Nov 2026, 23:28 UTC

CVSS 3.1 base score
2.8Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.12.8
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-03-31.

Patch
Available – fixed in 5.17.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade go-git and github.com/go-git/go-git to 5.17.1.

Affected software

ProductAffectedFixed in
go-gitgo-gitAffected
  • <5.17.1
Fixed in
  • 5.17.1
Gogithub.com/go-git/go-gitpkg:golang/github.com/go-git/go-gitOther threatsAffected
  • <5.17.1
Fixed in
  • 5.17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade go-git to version 5.17.1 or later, where this issue has been fixed. No other mitigation is required as the vulnerability is patched in this release.

Description

CVE-2026-33762 is a low-severity vulnerability in the go-git library prior to version 5.17.1. It involves improper validation of the path name prefix length in the index decoder for Git index format version 4. This flaw can cause an out-of-bounds slice operation leading to a runtime panic during normal index parsing. Only format version 4 is affected; earlier formats v2 and v3 are not vulnerable. The issue has been fixed in go-git version 5.17.1.

References

Community reviews

Loading reviews…