Skip to main content
VulnerabilityPublished Updated

CVE-2026-41506: go-git · Insufficiently Protected Credentials

Affects go-gitSource GCVE Database

0

Not known to be exploited · CVSS 4.7 Medium : upgrade to 6.0.0-alpha.2 or 5.18.0 when convenient.

Data as of 27 Oct 2026, 00:12 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.0.0-alpha.2, 5.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/go-git/go-git to 6.0.0-alpha.2 or 5.18.0.

Affected software

ProductAffectedFixed in
Gogithub.com/go-git/go-gitpkg:golang/github.com/go-git/go-gitOther threatsAffected
  • <5.18.0
  • <6.0.0-alpha.2
Fixed in
  • 5.18.0
  • 6.0.0-alpha.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade go-git to version 5.18.0 or later, or 6.0.0-alpha.2 or later, where this vulnerability has been patched. No other mitigation is required as the issue is fixed in these versions.

Description

go-git versions prior to 5.18.0 and 6.0.0-alpha.2 contain a vulnerability where HTTP authentication credentials may be leaked when following redirects during smart-HTTP clone and fetch operations. This issue has been fixed in versions 5.18.0 and 6.0.0-alpha.2.

References

Community reviews

Loading reviews…