Skip to main content
VulnerabilityPublished Updated

CVE-2026-109286: open-webui · Origin Validation Error

Affects open-webuiSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 0.11.4 soon.

Data as of 26 Oct 2026, 13:07 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-18.

Patch
Available – fixed in 0.11.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade open-webui to 0.11.4.

Affected software

ProductAffectedFixed in
open-webuiopen-webuiAffected
  • >=0.7.0 <0.11.4
Fixed in
  • 0.11.4
PyPIopen-webuipkg:pypi/open-webuiOther threatsAffected
  • >=0.7.0 <0.11.4
Fixed in
  • 0.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Open WebUI to version 0.11.4 or later, where this vulnerability is fixed. No other mitigation is indicated or required according to the vendor advisory.

Description

Open WebUI versions from 0.7.0 up to but not including 0.11.4 have a cross-origin message handling vulnerability in the SyncStatsModal component. This flaw allows any website to steal a signed-in user's session token by sending unvalidated verify:chat messages. Attackers can exploit a path traversal in the chat ID to redirect authenticated requests to the authentication endpoint, thereby obtaining the victim's JWT token and gaining full API access. The vulnerability is fixed in version 0.11.4.

References

Community reviews

Loading reviews…