Skip to main content
VulnerabilityPublished Updated

CVE-2026-109289: open-webui · Insufficient Session Expiration

Affects open-webuiSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.11.4 when convenient.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-13.

Patch
Available – fixed in 0.11.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade open-webui to 0.11.4.

Affected software

ProductAffectedFixed in
open-webuiopen-webuiAffected
  • >=0.8.8 <0.11.4
Fixed in
  • 0.11.4
PyPIopen-webuipkg:pypi/open-webuiOther threatsAffected
  • >=0.8.8 <0.11.4
Fixed in
  • 0.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Open WebUI to version 0.11.4 or later, where this improper authorization vulnerability is fixed. No other mitigation is indicated or required.

Description

Open WebUI versions from 0.8.8 up to but not including 0.11.4 have an authorization vulnerability where deactivated users can continue executing terminal commands via an already open terminal WebSocket. The vulnerability arises because the terminal proxy route only checks access on the first message, allowing continued command execution and file operations despite user deactivation. This issue is fixed in version 0.11.4.

References

Community reviews

Loading reviews…