Skip to main content
VulnerabilityPublished

CVE-2026-109518: Debian APT · UNIX Hard Link

Affects Debian APTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High · fixed in 3.3.6 : patch Debian APT soon.

Data as of 4 Nov 2026, 16:43 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (canonical)CVSS 4.07.7
Patch
Available – fixed in 3.3.6, 3.2.1, 3.0.4 +17
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
APTaptAffected
  • <1.2.36
  • >=1.4.0 <1.4.12
  • >=1.6.0 <1.6.19
  • >=1.8.0 <1.8.2.4
  • >=1.8.3 <=1.8.5
  • >=2.0.0 <2.0.12
  • >=2.2.0 <2.2.5
  • >=2.4.0 <2.4.15
  • >=2.6.0 <2.6.2
  • >=2.8.0 <2.8.4
  • >=3.0.0 <3.0.4
  • >=3.2.0 <3.2.1
  • >=3.3.0 <3.3.6
Fixed in
  • 3.3.6
  • 3.2.1
  • 3.0.4
  • 2.8.4
  • 2.6.2
  • 2.4.15
  • 2.2.5
  • 2.0.12
  • 1.8.2.4
  • 1.6.19
  • 1.4.12
  • 1.2.36
APTaptAffected
  • >=3.3.0 <3.3.3ubuntu0.1
Fixed in
  • 3.3.3ubuntu0.1
APTaptAffected
  • >=3.2.0 <3.2.1ubuntu0.1
Fixed in
  • 3.2.1ubuntu0.1
APTaptAffected
  • >=2.8.0 <2.8.4ubuntu0.1
Fixed in
  • 2.8.4ubuntu0.1
APTaptAffected
  • >=2.4.0 <2.4.15ubuntu0.1
Fixed in
  • 2.4.15ubuntu0.1
APTaptAffected
  • >=2.0.0 <2.0.12+esm1
Fixed in
  • 2.0.12+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions of APT are available starting from 1.6.19, 1.8.2.4, 2.0.12, 2.2.5, 2.4.15, 2.6.2, 2.8.4, 3.0.4, 3.2.1, and 3.3.6. Users should upgrade to these or later versions to remediate the vulnerability. Systems running older versions with default Acquire::Retries settings (zero) are not affected. No other mitigations are specified.

Description

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges. The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

References

Community reviews

Loading reviews…