Skip to main content
VulnerabilityPublished

CVE-2026-100235: zookeeper · Incorrect authorization due to a time-of-check to time-of-use (TOCTOU) race condition in the setACL

Affects zookeeperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-100235· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium · fixed in 3.8.8 : update zookeeper when convenient.

Data as of 4 Nov 2026, 15:18 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.06.0
Patch
Available – fixed in 3.8.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threatsAffected
  • <=3.9.6
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ZooKeeper to version 3.8.8 or 3.9.7, where this issue is fixed. No other mitigation or temporary workaround is indicated. Applying the official fix is the recommended remediation.

Description

A time-of-check to time-of-use (TOCTOU) race condition in Apache ZooKeeper's setACL request handling allows a client to perform operations with permissions that have been revoked but not yet fully enforced. This can enable unauthorized actions such as committing writes or deletes after losing write access or re-granting full permissions persistently. The vulnerability affects Apache ZooKeeper versions up to and including 3.9.6. Upgrading to versions 3.8.8 or 3.9.7 resolves the issue.

References

Community reviews

Loading reviews…