Skip to main content
VulnerabilityPublished

CVE-2026-109936: Otter Blocks (WordPress plugin) · Cross-site Scripting

Affects Otter Blocks (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.8 soon.

Data as of 29 Oct 2026, 19:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-23.

Patch
Available – fixed in 3.2.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Otter Blocks (WordPress plugin) to 3.2.8.

Affected software

ProductAffectedFixed in
Otter BlocksAffected
  • <3.2.8
Fixed in
  • 3.2.8

AI-suggested

Upgrade the Otter Blocks plugin to version 3.2.8 or later, where this vulnerability is fixed. No other mitigation is required as the fix is officially available.

Description

CVE-2026-109936 is a stored Cross-Site Scripting (XSS) vulnerability in the Otter Blocks WordPress plugin versions before 3.2.8. The flaw arises because the plugin does not properly limit a pattern used to rewrite dynamic-content tokens, allowing the pattern to consume the closing quote of an HTML attribute and inject unescaped data as new attributes. This enables unauthenticated attackers to inject malicious scripts that execute in the browsers of any visitors viewing the affected pages, including administrators.

References

Community reviews

Loading reviews…