Skip to main content
VulnerabilityPublished

CVE-2026-110808: Essential Addons for Elementor (WordPress plugin) · Improper Privilege Management

Affects Essential Addons for Elementor (WordPress plugin)Source CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade to 6.8.8 soon.

Data as of 31 Oct 2026, 06:21 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 6.8.8

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Essential Addons for Elementor (WordPress plugin) to 6.8.8.

Affected software

ProductAffectedFixed in
Essential Addons for ElementorAffected
  • >=6.6.0 <6.8.8
Fixed in
  • 6.8.8

AI-suggested

Upgrade the Essential Addons for Elementor plugin to version 6.8.8 or later, where this vulnerability is fixed. Versions 6.6.0 through 6.8.7 remain vulnerable despite previous partial fixes. No other mitigation is indicated by the vendor advisory.

Description

A privilege management vulnerability exists in the Essential Addons for Elementor WordPress plugin before version 6.8.8. Authenticated users with Author-level access or higher can manipulate the role assigned to accounts created via the plugin's registration form, potentially granting higher privileges such as Editor to new accounts, including those created by unauthenticated visitors. Versions 6.6.0 through 6.8.7 remain vulnerable due to an incomplete fix of a previous issue (CVE-2026-5193).

References

Community reviews

Loading reviews…