CVE-2026-62990: shopperlabs shopper · Cross-site Scripting
Affects shopperlabs shopperSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 3.0.0-beta.3 or 2.10.1 soon.
Data as of 30 Oct 2026, 21:36 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 8.7 |
|---|
- Patch
- Available – fixed in 3.0.0-beta.3, 2.10.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade shopper and shopperlabs/shopper to 3.0.0-beta.3 or 2.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| shopperlabsshopper | Affected
| Fixed in
|
| shopperlabsshopper | Affected
| Fixed in
|
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Shopper to version 2.10.1 or later, or 3.0.0-beta.3 or later, where this vulnerability is fixed. The vendor advisory confirms these versions address the issue by restricting executable media uploads and improving content handling. Until upgrade, administrators should avoid opening uploaded SVG or HTML files from users with upload permissions.
Description
CVE-2026-62990 is a high-severity cross-site scripting (XSS) vulnerability in the Shopper headless e-commerce admin panel. Authenticated back-office staff with content-upload permissions can upload executable media files, including SVG and HTML, which execute scripts in the administrator's session when opened. This can lead to unauthorized creation of attacker-controlled administrator accounts with full access to sensitive data and management functions. The vulnerability affects versions from 2.0.0 prior to 2.10.1 and prerelease versions 3.0.0-beta.1 and beta.2. It is fixed in versions 2.10.1 and 3.0.0-beta.3.
References
- github.com/shopperlabs/shopper/security/advisories/GHSA-vmvv-x5cp-2qv6 (opens in a new tab)
- github.com/shopperlabs/shopper/pull/595 (opens in a new tab)
- github.com/shopperlabs/shopper/pull/597 (opens in a new tab)
- github.com/shopperlabs/shopper/commit/12be681db5f603a364d5f03f1974ff2a20e99b99 (opens in a new tab)
- github.com/shopperlabs/shopper/commit/ad2c5b9b968ff49c37130c6b9d1dba7f20eebbf6 (opens in a new tab)
- github.com/shopperlabs/shopper/compare/v3.0.0-beta.1...v3.0.0-beta.3 (opens in a new tab)
- github.com/shopperlabs/shopper/releases/tag/v2.10.1 (opens in a new tab)
- github.com/shopperlabs/shopper/releases/tag/v3.0.0-beta.3 (opens in a new tab)