CVE-2026-47744: shopperlabs shopper · Improper Privilege Management
Affects shopperlabs shopperSource CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 2.8.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.8.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade shopper and shopperlabs/shopper to 2.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| shopperlabsshopper | Affected
| Fixed in
|
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in shopper version 2.8.0. Users should upgrade to version 2.8.0 or later to remediate this issue. Until upgrading, restrict authenticated access to trusted users only to minimize risk.
Description
CVE-2026-47744 is a critical improper privilege management vulnerability in shopperlabs shopper versions prior to 2.8.0. It involves two authorization defects that allow any authenticated user with low privileges to escalate to full administrator rights. Specifically, the team settings page lacks proper authorization checks, enabling users to create roles and delete administrators. Additionally, write actions in role permissions are improperly gated by a read-only permission, allowing arbitrary permission grants. This combined flaw permits complete takeover of the RBAC system and removal of legitimate administrators. The vulnerability is fixed in version 2.8.0.