Skip to main content
VulnerabilityPublished Updated

CVE-2026-110870: nodemailer · Improper Input Validation

Affects nodemailerSource CVE Database V5

0

Public exploit available · CVSS 6.9 Medium : upgrade to 10.0.13 as a priority.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-26.

Patch
Available – fixed in 10.0.13
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 32 minutes before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 12 days after disclosure

  4. In Threat Radar

    record ingested

    , 12 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nodemailer to 10.0.13.

Affected software

ProductAffectedFixed in
nodemailernodemailerAffected
  • >=3.0.0 <10.0.13
Fixed in
  • 10.0.13
npmnodemailerpkg:npm/nodemailerOther threatsAffected
  • >=3.0.0 <10.0.13
Fixed in
  • 10.0.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nodemailer to version 10.0.13 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

Nodemailer versions from 3.0.0 up to but not including 10.0.13 have an improper input validation vulnerability in the address parser. This flaw allows RFC 5322 comments inside angle-bracket email addresses to remain unstripped, enabling attackers to craft recipient addresses with parenthesized comments in the domain part. Such malformed addresses can cause delivery rejection or parser conflicts that may bypass domain allow-lists. The issue is fixed in version 10.0.13.

References

Community reviews

Loading reviews…