Skip to main content
VulnerabilityPublished Updated

CVE-2026-110871: nodemailer · Uncontrolled Resource Consumption

Affects nodemailerSource CVE Database V5

0

Public exploit available · CVSS 7.1 High : upgrade to 10.0.10 as a priority.

Data as of 26 Oct 2026, 22:34 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-20.

Patch
Available – fixed in 10.0.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 32 minutes before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 6 days after disclosure

  4. In Threat Radar

    record ingested

    , 12 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nodemailer to 10.0.10.

Affected software

ProductAffectedFixed in
nodemailernodemailerAffected
  • >=3.0.0 <10.0.10
Fixed in
  • 10.0.10
npmnodemailerpkg:npm/nodemailerOther threatsAffected
  • >=3.0.0 <10.0.10
Fixed in
  • 10.0.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nodemailer to version 10.0.10 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated.

Description

Nodemailer versions from 3.0.0 up to but not including 10.0.10 contain a denial of service vulnerability in the MessageParser.parseHeaders function. This flaw allows attackers to exhaust CPU resources by supplying large recipient lists or headers that unfold into tens of thousands of continuation lines, causing quadratic header unfolding. The attack blocks the Node.js event loop during DKIM signing, resulting in service disruption.

References

Community reviews

Loading reviews…