CVE-2026-1114: parisneo/lollms · Improper Access Control
Affects parisneo/lollmsSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.2.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parisneo/lollms to 2.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parisneoparisneo/lollms | Affected
| Fixed in– |
GitHubparisneo/lollmspkg:github/parisneo/lollmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade parisneo/lollms to version 2.2.0 or later, where the vulnerability is fixed. No other mitigation guidance is provided. Patch status is confirmed by the version update.
Description
CVE-2026-1114 is a critical vulnerability in parisneo/lollms version 2.1.0 caused by improper access control due to a weak secret key used for signing JSON Web Tokens (JWT). This weakness allows an attacker to perform an offline brute-force attack to recover the secret key. With the recovered key, attackers can forge administrative tokens, enabling unauthorized privilege escalation and access to restricted endpoints. The vulnerability is fixed in version 2.2.0.