CVE-2026-112111: Bootstrap Shortcodes (WordPress plugin) · Cross-site Scripting
Affects Bootstrap Shortcodes (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.4.6 when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Bootstrap Shortcodes and bootstrap-shortcodes to 3.4.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Bootstrap Shortcodesbootstrap-shortcodes | Affected
| Fixed in
|
GitHubbootstrap-shortcodespkg:github/bootstrap-shortcodesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 3.4.6 or later of the Bootstrap Shortcodes plugin should be applied once available. Until then, restrict Contributor-level access and above to trusted users only and avoid using the vulnerable shortcode with untrusted input.
Description
The Bootstrap Shortcodes plugin for WordPress before 3.4.6 is vulnerable to stored XSS via the id attribute of the [bs_tcontent] shortcode. The bs_tcontent() shortcode handler in inc/bs_tabs.php emits the id attribute value into an unquoted HTML attribute. esc_attr() is applied, but it does not encode space characters, so a space in the supplied value terminates the attribute and any following text is parsed as additional HTML attributes, including JavaScript event handlers. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web script that executes in the browser of any user who views the page and interacts with the injected element.
References
- github.com/TheWebShop/bootstrap-shortcodes/commit/c26659ccb6ddb871c7dee1b77cb81cad63e7a75b (opens in a new tab)
- wordpress.org/plugins/bootstrap-shortcodes/ (opens in a new tab)
- github.com/TheWebShop/bootstrap-shortcodes/releases/tag/3.4.6 (opens in a new tab)
- plugins.trac.wordpress.org/browser/bootstrap-shortcodes/tags/3.4.4/inc/bs_tabs.php (opens in a new tab)
- wordpress.org/plugins/bootstrap-shortcodes/ (opens in a new tab)