Skip to main content
VulnerabilityPublished

CVE-2026-112306: nocobase · SQL Injection

Affects nocobaseSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High.

Data as of 26 Oct 2026, 13:07 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-19.

CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
nocobasenocobaseAffected
  • <=2.2.28
Fixed in–
GitHubnocobasepkg:github/nocobaseOther threatsAffected
  • <=2.2.28
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects versions up to 2.2.28, upgrading to a version later than 2.2.28 (once available) is recommended. Until a fix is released, restrict privileged user access to trusted personnel only and monitor for suspicious activity involving the sqlCollection:setFields action.

Description

NocoBase plugin-collection-sql versions up to 2.2.28 contain an SQL injection vulnerability that allows privileged users to bypass input validation and store malicious SQL commands. This flaw enables attackers with access to the collection-sql snippet to replace safe queries with harmful statements that execute on reload, potentially exposing sensitive data such as PostgreSQL password hashes or reading files on the server.

References

Community reviews

Loading reviews…