CVE-2026-112362: @fastify/express · Interpretation Conflict
Affects @fastify/expressSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.0.9 as a priority.
Data as of 27 Oct 2026, 11:57 UTC
- Patch
- Available – fixed in 4.0.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade @fastify/express to 4.0.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| @fastify/express@fastify/express | Affected
| Fixed in
|
npm@fastify/expresspkg:npm/@fastify/expressOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade @fastify/express to version 4.0.9 or later, where the issue is fixed. Alternatively, avoid enabling the non-default ignoreDuplicateSlashes option. As a workaround, enforce authentication and other critical middleware in Fastify hooks such as preHandler that run after the router resolves the request, ensuring middleware is applied regardless of path normalization differences.
Description
@fastify/express versions 4.0.5 through 4.0.8 contain a vulnerability where, if Fastify is configured with the non-default ignoreDuplicateSlashes option, path-scoped Express middleware may be bypassed. This occurs because Fastify's router normalizes duplicate slashes differently than Express when handling absolute-form request targets, allowing requests to reach scoped routes without passing through authentication or authorization middleware. The issue is fixed in version 4.0.9.