Skip to main content
CVE-2026-115700VulnerabilityPublished

hackney_url · Interpretation Conflict Vulnerability

Source GCVE Database

0
Authoritative record:CVE-2026-115700· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.9.0 when convenient.

Data as of 26 Oct 2026, 16:53 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.9.0, f19561a0b422376348c91537e51377ab7325f4ee
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hackney to 4.9.0; hackney to f19561a0b422376348c91537e51377ab7325f4ee.

Affected software

ProductAffectedFixed in
benoitchackneyAffected
  • >=4.0.1 <4.9.0
Fixed in
  • 4.9.0
hackneybenoitc/hackneyAffected
  • ≥ 452620a92ec1da2e6b4862a049a2a4f04b42068f, < f19561a0b422376348c91537e51377ab7325f4ee
Fixed in
  • f19561a0b422376348c91537e51377ab7325f4ee
Hexhackneypkg:hex/hackneyOther threatsAffected
  • >=4.0.1 <4.9.0
Fixed in
  • 4.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects hackney versions from 4.0.1 before 4.9.0, upgrading to version 4.9.0 or later is implied to resolve the issue. Users should verify with the official vendor advisory or release notes for confirmed fixes and apply updates accordingly.

Description

A Server Side Request Forgery (SSRF) vulnerability exists in the hackney_url component of the benoitc hackney library. It arises from an interpretation conflict when handling percent-encoded bracketed IPv6 literals or IP literals with trailing dots. This causes the library to bypass allowlist checks and connect to unintended IP addresses. The issue affects hackney versions from 4.0.1 up to but not including 4.9.0.

References

Community reviews

Loading reviews…