Skip to main content
VulnerabilityPublished

CVE-2026-113654: apostrophecms apostrophe · Cross-site Scripting

Affects apostrophecms apostropheSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.33.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.33.0, 2.18.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apostrophe to 4.33.0; sanitize-html to 2.18.0.

Affected software

ProductAffectedFixed in
apostrophecmsapostropheAffected
  • <4.33.0
Fixed in
  • 4.33.0
apostrophecmssanitize-htmlAffected
  • <2.18.0
Fixed in
  • 2.18.0
npmsanitize-htmlpkg:npm/sanitize-htmlOther threatsAffected
  • <2.18.0
Fixed in
  • 2.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade sanitize-html to version 2.18.0 or later to address the improper sanitization of the noscript tag. Additionally, upgrade ApostropheCMS to version 4.33.0 or later where this fix is incorporated. No other specific mitigations are indicated. Patch status is confirmed by the vendor advisory indicating the fix in sanitize-html 2.18.0.

Description

ApostropheCMS versions prior to 4.33.0 are affected by a cross-site scripting (XSS) vulnerability due to improper sanitization of HTML content involving the noscript tag. This issue arises from the sanitize-html library versions before 2.18.0, where the non-default nonTextTags configuration including noscript can prematurely end discard regions, allowing potentially malicious content to survive sanitization and render in browsers. The vulnerability is fixed in sanitize-html version 2.18.0.

References

Community reviews

Loading reviews…