CVE-2026-113659: apostrophecms apostrophe · Cross-site Scripting
Affects apostrophecms apostropheSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.33.0 when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.33.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade apostrophe and apostrophecms/apostrophe to 4.33.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| apostrophecmsapostrophe | Affected
| Fixed in
|
npmapostrophecms/apostrophepkg:npm/apostrophecms/apostropheOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ApostropheCMS to version 4.33.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
ApostropheCMS versions prior to 4.33.0 contain a cross-site scripting (XSS) vulnerability in the admin bundle. An unauthenticated attacker can craft a link with a specially formed query string that, when loaded by an authenticated admin user, triggers prototype pollution via the __proto__, constructor, or prototype keys. This leads to unsafe DOM manipulation and script execution in the victim's session. Anonymous users are not affected as they do not load the admin context. The issue is fixed in version 4.33.0.
References
- github.com/apostrophecms/apostrophe/security/advisories/GHSA-m2m5-rw3w-cwmj (opens in a new tab)
- github.com/apostrophecms/apostrophe/commit/9500b8b0e1d630d5e07fbb5fd2c25ed0943845ce (opens in a new tab)
- github.com/apostrophecms/apostrophe/commit/f84fd41cbf6c22eb8d0008fc9c25df1f7130b350 (opens in a new tab)
- github.com/apostrophecms/apostrophe/releases/tag/apostrophe@4.33.0 (opens in a new tab)