Skip to main content
VulnerabilityPublished

CVE-2026-114427: GutenKit (WordPress plugin) · Cross-site Scripting

Affects GutenKit (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.5.5 soon.

Data as of 6 Nov 2026, 06:33 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.5.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GutenKit (WordPress plugin) to 2.5.5.

Affected software

ProductAffectedFixed in
GutenKitAffected
  • >=2.5.0 <2.5.5
Fixed in
  • 2.5.5

AI-suggested

Upgrade the GutenKit plugin to version 2.5.5 or later, where this vulnerability is fixed. No additional mitigation is required once the plugin is updated. Sites running WordPress 7.0 or later are not affected by this issue.

Description

A Cross-site Scripting (XSS) vulnerability exists in the GutenKit WordPress plugin versions 2.5.0 through 2.5.4. It allows users with Author role or higher to inject JavaScript by exploiting improper sanitization of custom CSS saved against posts. This malicious script executes in the browsers of visitors viewing the affected posts. The issue affects sites running WordPress versions below 7.0. The vulnerability is fixed in GutenKit version 2.5.5.

References

Community reviews

Loading reviews…